[10-29-2025] Unable to sign in visitors via dashboard

Incident Report for Envoy

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 14:45 PDT

Update

This issue was successfully resolved at 2:40 PM PDT.
Posted Oct 29, 2025 - 14:40 PDT

Monitoring

The Envoy Visitors Kiosk app is once again available for download from the App Store.
Posted Oct 29, 2025 - 13:58 PDT

Investigating

We are currently experiencing an issue preventing a subset of users from signing in visitors through the Envoy Kiosk. Our team is actively investigating the root cause and working to restore functionality as soon as possible. While are investigating the issue, Envoy Visitors Kiosk app is unavailable to download via app store.

We sincerely apologize for the inconvenience and appreciate your patience while we work to resolve this issue. For any further questions, please contact Envoy Support via hi@envoy.com.
Posted Oct 29, 2025 - 03:58 PDT
This incident affected: Visitor registration.