Envoy Kiosk v5.59.0 has been released to the App Store with changes aimed at stabilizing the printer functionality issues. We are monitoring the situation to confirm the fix is working as expected.
Posted Jan 24, 2026 - 18:35 PST
Update
We continue to investigate reports of customers experiencing difficulties printing badges in the Envoy Kiosk App. Our team has identified a potential code issue that may be contributing to this behavior and is working to confirm the root cause. We will provide another update as soon as we have more information.
Posted Jan 23, 2026 - 18:24 PST
Investigating
We are currently investigating issues related to Visitors device connectivity that may be impacting badge printing functionality for some customers. Our team is actively working to identify the root cause and assess for a resolution; updates will be shared as more information becomes available.
We appreciate your understanding - for any additional questions or feedback, please contact the Customer Support team via live chat or hi@envoy.com!