Reports of users being unable to log in
Incident Report for Envoy
Resolved
Our payments processor has resolved their issues and dashboard access has been restored
Posted over 1 year ago. Jun 07, 2018 - 17:57 PDT
Update
Follow https://status.stripe.com/ for additional details
Posted over 1 year ago. Jun 07, 2018 - 17:35 PDT
Identified
Our payments processor is experiencing issues, causing users to have difficulty logging in and accessing certain features.
Posted over 1 year ago. Jun 07, 2018 - 17:33 PDT