Our third-party email delivery provider is reporting recovery in delivery to Microsoft-hosted mail services. We are actively monitoring delivery and will confirm once we have verified that messages are flowing normally.
Posted Sep 04, 2026 - 07:06 PDT
Identified
We have identified the cause as an issue with our third-party email delivery provider, whose messages to Microsoft-hosted mail services are currently being throttled. This affects Envoy emails sent to recipients on Microsoft services such as Microsoft 365 and Outlook — including sign-in verification, invite, and visitor notification emails.
Affected messages are queued and retried automatically rather than lost, and should arrive once normal delivery is restored. As per our investigation, email to all other recipients is unaffected, and no action is required from customers.
Our provider is actively investigating; we will post another update within the hour or sooner if anything changes.
Posted Sep 04, 2026 - 05:17 PDT
Update
We are continuing to investigate this issue.
Posted Sep 04, 2026 - 05:14 PDT
Investigating
We are currently investigating this issue.
Posted Sep 04, 2026 - 05:13 PDT
This incident affected: Notifications (Email notifications).