Monitoring Potential Impact from Ongoing Cloudflare Outage

Incident Report for Envoy

Resolved

Cloudflare has resolved the outage as of 2:31 PM PST. Our services remained stable throughout the incident, and no impact was observed. We will continue to monitor for any residual effects, but no further issues are expected.

Thank you for your patience. For more details, you can refer to Cloudflare's status page: https://www.cloudflarestatus.com/
Posted Jun 12, 2025 - 21:47 PDT

Investigating

Our partner, Cloudflare, is currently experiencing a major outage that may impact services that depend on their infrastructure. At this time, our systems remain fully operational, but we are actively monitoring the situation to stay ahead of any potential disruptions.

We will provide updates here as needed. You can also follow Cloudflare's status directly at: https://www.cloudflarestatus.com/
Posted Jun 12, 2025 - 11:57 PDT
This incident affected: Infrastructure (Cloudflare Load Balancing and Monitoring, Cloudflare Cloudflare Authoritative DNS, Cloudflare Dashboard, Cloudflare API).