[2025-08-22] Envoy Dashboard slow load times due to Cloudflare issue

Incident Report for Envoy

Resolved

The earlier slow load times in parts of the Envoy dashboard have been resolved as Cloudflare has addressed the incident. Performance is back to normal.
Posted Aug 23, 2025 - 00:18 PDT

Monitoring

We are currently experiencing slow load times in parts of the Envoy dashboard due to an ongoing Cloudflare outage. We are monitoring Cloudflare’s status page closely and will keep you posted as soon as we know more.

For more details on the Cloudflare incident, please see https://www.cloudflarestatus.com.
Posted Aug 22, 2025 - 14:16 PDT
This incident affected: Envoy Dashboard.