Delay in delivering email notifications
Incident Report for Envoy
Resolved
The issue impacting email notifications and visitor invites has now been resolved by our email delivery partner.

Thank you for your patience, and we apologize for any inconvenience caused.
Posted Oct 25, 2024 - 12:59 PDT
Identified
We’re currently experiencing a delay in email notifications and visitor invites due to service delays with our email delivery partner. We’re closely monitoring the situation. Thank you for your patience, and we apologize for any inconvenience this may cause.
Posted Oct 25, 2024 - 10:04 PDT
This incident affected: Notifications (Core) (Email notifications).