2.14.2025 Envoy EU Scheduled Maintenance
Scheduled for Feb 14, 19:00 - 20:00 PST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 30, 2025 - 09:39 PST
Scheduled
Envoy EU will be undergoing maintenance on Friday, February 14th from 7pm - 8pm PST; we anticipate some disruption during this time frame.

For questions/concerns, please contact Customer Support at hi@envoy.com or via the live chat messenger.
Posted Jan 30, 2025 - 09:37 PST
This scheduled maintenance affects: Envoy dashboard, Visitor registration, Deliveries, Rooms, Desks, and Mobile.