Deliveries kiosks are failing
Incident Report for Envoy
Resolved
The issue is resolved and Deliveries kiosks should be operating as expected. If you still experience any issues, please contact [email protected].
Posted 11 months ago. May 18, 2018 - 09:21 PDT
Identified
Our engineers have identified the issue and are implementing a fix.
Posted 11 months ago. May 18, 2018 - 09:09 PDT
Investigating
We're investigating reports that the Envoy Deliveries kiosks are not loading and package lookups are failing.
Posted 11 months ago. May 18, 2018 - 08:59 PDT