Some users are unable to login with Two-Factor-Authentication (2FA) on EU dashboard
Incident Report for Envoy
Resolved
The incident related to two-factor authentication in our Envoy EU instance has been resolved at approximately 5:45pm PT.

If you experience any ongoing disruptions, please contact Envoy Customer Support via the chat messenger or via hi@envoy.com.
Posted Dec 17, 2024 - 19:13 PST
Identified
The issue has been identified, and a workaround is now available for existing EU customers. A formal fix will follow for new customers leveraging Envoy EU. For assistance, please contact Envoy Customer Support via the chat messenger or at hi@envoy.com.
Posted Dec 17, 2024 - 09:10 PST
Investigating
We are aware of an issue affecting some users who cannot log in due to email deliverability problems with two-factor authentication. This appears to be impacting a subset of companies using our EU dashboard.

Our team is actively investigating the root cause and working to resolve the issue as quickly as possible.
Posted Dec 17, 2024 - 01:52 PST
This incident affected: Envoy dashboard.