[08/07/2025] - Envoy Sign-up Temporarily Unavailable

Incident Report for Envoy

Resolved

The signup experience has been restored
Posted Aug 18, 2025 - 13:08 PDT

Monitoring

We’re currently updating the Envoy sign-up page, which may cause temporary delays in account creation. For immediate access, please contact our Customer Support team at hi@envoy.com.
Posted Aug 07, 2025 - 22:17 PDT

Identified

We are currently making updates to the Envoy signup experience. If are in need of immediate access, please reach out to Customer Support via hi@envoy.com for assistance.

We apologize for any disruption this may cause & appreciate your patience!
Posted Aug 07, 2025 - 20:48 PDT
This incident affected: Envoy Dashboard.