Service Disruption - Partial
Incident Report for Envoy
Postmortem

On March 19th at 6:24 AM PDT, Envoy experienced an overload to our database causing web requests to slow down across the system, leading to a degraded mobile apps and web dashboard performance and slow badge event processing. Our team took measures to restore the functionality to normal by relieving the database of queued requests.

An internal post-mortem will be organized to analyze the incident and note key learnings, and action items. If you have any concerns or require additional information, please don't hesitate to contact our Customer Support team via hi@envoy.com or contact your dedicated account manager.

Posted Mar 19, 2024 - 16:47 PDT

Resolved
Our Engineering team has implemented a solution to the latency issues noted within our mobile apps and web dashboard; residual impact to our access control integrations have also been addressed. An internal post-mortem will be organized to analyze the incident and note key learnings, and action items.

If you have any concerns or require additional information, please don't hesitate to contact our Customer Support team via hi@envoy.com or your dedicated account manager.
Posted Mar 19, 2024 - 16:46 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2024 - 16:44 PDT
Update
We are continuing to investigate this issue.
Posted Mar 19, 2024 - 09:46 PDT
Investigating
We are currently experiencing a partial service disruption to our mobile app. This may cause pages to be slow or unresponsive

Our engineering team is working to identify the root cause and implement a solution. Logged in users may be affected.
Posted Mar 19, 2024 - 06:44 PDT
This incident affected: Integrations (Auto Check-in via Access Control) and Mobile.