Unable to create new invite
Incident Report for Envoy
Resolved
This issue has been resolved.
Posted May 11, 2022 - 12:31 PDT
Monitoring
A fix has been deployed and we are monitoring
Posted May 11, 2022 - 12:28 PDT
Investigating
We are aware of an issue where users are unable to create a new invite via the dashboard

When you click on a new invite, the page just keeps loading

We are investigating the issue
Posted May 11, 2022 - 12:05 PDT
This incident affected: Envoy dashboard and Visitor registration.