8.2.24 Envoy - Guest Invite / Pre-Registration Email Disruption
Incident Report for Envoy
Resolved
Our Engineering team has resolved the issue related to pre-registration emails not being delivered; an internal post-mortem will conducted to identify the root cause and be provided in line shortly.

For any issues related to this matter, please contact Envoy Support at hi@envoy.com.
Posted Aug 02, 2024 - 11:43 PDT
Investigating
We are currently investigating reports of guest invite (pre-registration emails) not being delivered; our Engineering team has been notified and an update will be provided shortly.

For any issues related to this matter, please contact Envoy Support at hi@envoy.com.
Posted Aug 02, 2024 - 10:18 PDT
This incident affected: Visitor registration.