Degraded performance on our dashboard
Incident Report for Envoy
Resolved
We have resolved the database issue that was causing slowness across the application
Posted 2 months ago. Jan 11, 2019 - 11:23 PST
Identified
We are experiencing problems with our dashboard loading slowly for users.
Posted 2 months ago. Jan 11, 2019 - 10:03 PST
This incident affected: Envoy dashboard.