Deliveries Kiosk App - unable to open or pair a new device

Incident Report for Envoy

Resolved

The Delivery Kiosk App has now returned to full functionality. Please contact Envoy Support (hi@envoy.com) if you are still experiencing any issues.
Posted Aug 11, 2025 - 04:38 PDT

Monitoring

We have identified the cause and implemented a fix and are monitoring the results.
Posted Aug 11, 2025 - 03:50 PDT

Investigating

We are currently investigating a reported issue with the Deliveries Kiosk App. Some users are reporting that the app will only shown the "Envoy" logo when it opens, and new devices are not able to be paired to a Delivery area.

Recipients are able to mark packages as 'collected' through their notification, or an Admin can manually mark it as collected through the Delivery Log.
Posted Aug 11, 2025 - 03:14 PDT
This incident affected: Workplace (Deliveries).