Trouble scheduling and accessing Desks on the mobile app and Dashboard
Incident Report for Envoy
Resolved
This incident has been resolved, our engineering team is monitoring the status closely.
Posted Apr 02, 2023 - 17:39 PDT
Monitoring
This incident has been resolved, our engineering team is monitoring the status closely
Posted Apr 02, 2023 - 17:25 PDT
Investigating
Our team has identified an issue with scheduling and booking desks

Our engineering team is working to identify the root cause and implement a solution.
Posted Apr 02, 2023 - 16:37 PDT
This incident affected: Envoy dashboard, Desks, and Mobile.