Completed
The scheduled maintenance has been completed.
Posted May 12, 2026 - 21:00 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 12, 2026 - 20:00 PDT
Scheduled
Envoy will be performing emergency maintenance today, May 12, 2026, from 8:00 to 9:00 p.m. PT. We anticipate some system disruption during this time.
For any questions or concerns, please contact Envoy Customer Support via live chat or at hi@envoy.com
Posted May 12, 2026 - 15:54 PDT
This scheduled maintenance affected: Envoy Dashboard, Visitor registration, Analytics, Mobile, Infrastructure (AWS s3-us-standard, Chargebee API, Cloudflare Load Balancing and Monitoring, Cloudflare Cloudflare Authoritative DNS, Cloudflare Dashboard, Cloudflare API, SendGrid API, AWS ec2-us-east-1, AWS eks-us-east-1, AWS rds-us-east-1, AWS elasticache-us-east-1, AWS s3-us-west-2, AWS redshift-us-east-1, AWS autoscaling-us-east-1, AWS rekognition-us-east-1, AWS kafka-us-east-1), Notifications (Email notifications, SMS notifications, Push notifications, Slack notifications), Workplace (Employee Registration, Desks, Deliveries, Rooms, Maps), and Integrations (Auto Check-in via Access Control, Auto-Check in via Wifi Integrations, Developer API, Partner Integrations).