Service Disruption - Partial
Incident Report for Envoy
Resolved
The issue has been resolved and all systems are fully operational. This afternoon we experienced an increase in traffic to our servers - our systems correctly responded by auto-scaling to meet demand but the request queues that were currently running became overwhelmed and stopped accepting new requests.

We have identified the cause of the stuck requests and have a fix in place to prevent this from causing service disruption should it occur again.

Apologies for any inconvenience caused, if you are still experiencing issues please reach out to hi@envoy.com or via the messenger on your dashboard and we'll be happy to assist.
Posted Jul 26, 2021 - 18:04 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 26, 2021 - 17:39 PDT
Investigating
We are currently experiencing a partial service disruption to our dashboard and mobile app.

Our engineering team is working to identify the root cause and implement a solution. Logged-in users may be affected.

We will send an additional update in the next 30 minutes.
Posted Jul 26, 2021 - 16:50 PDT
This incident affected: Envoy dashboard and Mobile.