Envoy products are experiencing an outage

Incident Report for Envoy

Resolved

This incident has been resolved.
Posted May 07, 2026 - 20:17 PDT

Update

We are continuing to monitor for any further issues.
Posted May 07, 2026 - 18:53 PDT

Monitoring

The issue has been identified, and we’re seeing improvements across all product functionality.
Posted May 07, 2026 - 18:40 PDT

Investigating

We are currently looking into the issue to identify the root cause.
Posted May 07, 2026 - 18:16 PDT
This incident affected: Envoy Dashboard, Visitor registration and Workplace (Deliveries, Rooms, Maps).