Some users unable to change Envoy password

Incident Report for Envoy

Resolved

The incident has been resolved, and our teams are continuing to monitor performance.
Posted Apr 22, 2024 - 08:15 PDT

Monitoring

We have identified the cause of this issue, a fix has been implemented and we are monitoring the results.
Posted Apr 22, 2024 - 07:04 PDT

Update

We are continuing to investigate this issue.
Posted Apr 22, 2024 - 05:14 PDT

Investigating

We have received reports that some users are seeing an error page when attempting to change their login password from dashboard.envoy.com

Our team is aware and currently investigating.
Posted Apr 22, 2024 - 05:14 PDT
This incident affected: Envoy Dashboard.