[10/14/2025] - Rooms tablets offline and showing blank screen

Incident Report for Envoy

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 20:03 PDT

Monitoring

We identified an issue that caused some room tablets to go offline and display a blank screen for a brief period. The tablets should now be fully operational.

If a tablet screen remains blank, please power cycle the device to restore functionality.

We apologize for the inconvenience and appreciate your patience while we resolved this issue.
Posted Oct 14, 2025 - 19:51 PDT
This incident affected: Workplace (Rooms).