App Store not loading on the Envoy Dashboard for Customers storing Visitor data in the EU database

Incident Report for Envoy

Resolved

The cause has been identified, a fix released and the incident has now been resolved.
Posted May 19, 2025 - 09:09 PDT

Investigating

We are currently investigating an issue for users with data stored in our EU data centre where the App store page is not loading on the Envoy Dashboard.
Posted May 19, 2025 - 08:36 PDT
This incident affected: Envoy Dashboard.