Email notifications impacted by downstream issues with our email provider
Incident Report for Envoy
Resolved
Our email provider has revolved the issues and email notifications are back to normal.
Posted about 1 year ago. May 17, 2018 - 12:18 PDT
Investigating
We are experiencing some problems with email notification deliveries due to issues with our email provider.
Posted about 1 year ago. May 17, 2018 - 10:23 PDT