Our email provider is experiencing connectivity issues
Incident Report for Envoy
Resolved
This incident has been resolved.
Posted 11 months ago. May 24, 2018 - 15:06 PDT
Monitoring
Our email provider is currently experiencing connectivity issues which may cause some email notifications to be delayed or not sent. We will update this page when they have resolved their issues.

Details here: http://status.mandrillapp.com/
Posted 11 months ago. May 24, 2018 - 11:01 PDT