Envoy Deliveries app loading slowly
Incident Report for Envoy
Resolved
There was an intermittent issue with our hosting provider that caused a percentage of our traffic to experience significant slowdowns. This has been resolved.
Posted Feb 21, 2018 - 16:03 PST
Investigating
We are investigating reports of slowdowns with the deliveries application
Posted Feb 21, 2018 - 13:41 PST